Skip to content

Commit

Permalink
www/nginx-devel: Fix PROPFIND fail with 500 on simlinks to non exist …
Browse files Browse the repository at this point in the history
…file/dir

Private patch: not reported to FreeBSD.
arut/nginx-dav-ext-module#56
  • Loading branch information
rozhuk-im committed Dec 28, 2020
1 parent 838490e commit d294bbe
Show file tree
Hide file tree
Showing 2 changed files with 16 additions and 0 deletions.
1 change: 1 addition & 0 deletions www/nginx-devel/Makefile.extmod
Original file line number Diff line number Diff line change
Expand Up @@ -90,6 +90,7 @@ HTTP_DAV_EXT_IMPLIES= HTTP_DAV
HTTP_DAV_EXT_USE= GNOME=libxml2,libxslt
HTTP_DAV_EXT_GH_TUPLE= arut:nginx-dav-ext-module:v3.0.0:dav_ext
HTTP_DAV_EXT_VARS= DSO_EXTMODS+=dav_ext
HTTP_DAV_EXT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_dav_ext_module.c

HTTP_EVAL_GH_TUPLE= openresty:nginx-eval-module:582bd25:eval
HTTP_EVAL_VARS= DSO_EXTMODS+=eval
Expand Down
15 changes: 15 additions & 0 deletions www/nginx-devel/files/extra-patch-ngx_http_dav_ext_module.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- ../nginx-dav-ext-module-3.0.0/ngx_http_dav_ext_module.c 2018-12-17 11:45:12.000000000 +0300
+++ ../nginx-dav-ext-module-3.0.0/ngx_http_dav_ext_module.c 2020-03-13 01:20:47.498199000 +0300
@@ -896,10 +896,9 @@
ngx_cpystrn(last, name.data, name.len + 1);

if (ngx_de_info(filename, &dir) == NGX_FILE_ERROR) {
- ngx_log_error(NGX_LOG_CRIT, r->connection->log, ngx_errno,
+ ngx_log_error(NGX_LOG_ERR, r->connection->log, ngx_errno,
ngx_de_info_n " \"%s\" failed", filename);
- rc = NGX_HTTP_INTERNAL_SERVER_ERROR;
- break;
+ continue;
}
}

0 comments on commit d294bbe

Please sign in to comment.