-
Notifications
You must be signed in to change notification settings - Fork 116
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
meta-balena-warrior: use cmake 3.20.1
Use cmake 3.20.1 to build rust v1.73.0 successfully. Change-type: patch
- Loading branch information
Showing
9 changed files
with
44 additions
and
170 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,8 @@ | ||
From 71085723f8028b3e1c4029fc1abe1243ac49ffc6 Mon Sep 17 00:00:00 2001 | ||
From ac9b8d316ff3e013bc9d3c063db99aa1f064ce6a Mon Sep 17 00:00:00 2001 | ||
From: Cody P Schafer <[email protected]> | ||
Date: Thu, 27 Apr 2017 11:35:05 -0400 | ||
Subject: [PATCH 1/5] CMakeDetermineSystem: use oe environment vars to load | ||
default toolchain file in sdk | ||
Organization: O.S. Systems Software LTDA. | ||
Subject: [PATCH] CMakeDetermineSystem: use oe environment vars to load default | ||
toolchain file in sdk | ||
|
||
Passing the toolchain by: | ||
|
||
|
@@ -20,15 +19,16 @@ because '-D' options are cache entries themselves. | |
Upstream-Status: Inappropriate [oe-core specific] | ||
Signed-off-by: Cody P Schafer <[email protected]> | ||
Signed-off-by: Otavio Salvador <[email protected]> | ||
|
||
--- | ||
Modules/CMakeDetermineSystem.cmake | 7 +++++++ | ||
1 file changed, 7 insertions(+) | ||
|
||
diff --git a/Modules/CMakeDetermineSystem.cmake b/Modules/CMakeDetermineSystem.cmake | ||
index 600d5580e..32d7f1945 100644 | ||
index bae270d..5bb6bc0 100644 | ||
--- a/Modules/CMakeDetermineSystem.cmake | ||
+++ b/Modules/CMakeDetermineSystem.cmake | ||
@@ -82,6 +82,13 @@ else() | ||
@@ -111,6 +111,13 @@ else() | ||
endif() | ||
endif() | ||
|
||
|
@@ -42,6 +42,3 @@ index 600d5580e..32d7f1945 100644 | |
# if a toolchain file is used, the user wants to cross compile. | ||
# in this case read the toolchain file and keep the CMAKE_HOST_SYSTEM_* | ||
# variables around so they can be used in CMakeLists.txt. | ||
-- | ||
2.18.0 | ||
|
122 changes: 0 additions & 122 deletions
122
...balena-warrior/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
From c783ceeef485c23e13c3d9f0418719cb0e0b86ee Mon Sep 17 00:00:00 2001 | ||
From 2d02ac91d5a5d72eaddba4894eaa6db3ed8fee62 Mon Sep 17 00:00:00 2001 | ||
From: Otavio Salvador <[email protected]> | ||
Date: Thu, 12 May 2011 15:36:03 +0000 | ||
Subject: [PATCH 3/5] cmake: support OpenEmbedded Qt4 tool binary names | ||
Organization: O.S. Systems Software LTDA. | ||
Subject: [PATCH] cmake: support OpenEmbedded Qt4 tool binary names | ||
|
||
The FindQt4 module looks for Qt4 binaries to be able to gather the | ||
paths used for compilation and also to be using during other processes | ||
|
@@ -20,15 +19,16 @@ Instead of find_program, _find_qt4_program is now used. | |
|
||
Signed-off-by: Moritz Blume <[email protected]> | ||
Signed-off-by: Otavio Salvador <[email protected]> | ||
|
||
--- | ||
Modules/FindQt4.cmake | 10 +++++----- | ||
1 file changed, 5 insertions(+), 5 deletions(-) | ||
|
||
diff --git a/Modules/FindQt4.cmake b/Modules/FindQt4.cmake | ||
index 847a798af..7ad981879 100644 | ||
index 3993968..b2a8585 100644 | ||
--- a/Modules/FindQt4.cmake | ||
+++ b/Modules/FindQt4.cmake | ||
@@ -517,7 +517,7 @@ endfunction() | ||
@@ -518,7 +518,7 @@ endfunction() | ||
|
||
set(QT4_INSTALLED_VERSION_TOO_OLD FALSE) | ||
|
||
|
@@ -37,7 +37,7 @@ index 847a798af..7ad981879 100644 | |
_qt4_find_qmake("${_QT4_QMAKE_NAMES}" QT_QMAKE_EXECUTABLE QTVERSION) | ||
|
||
if (QT_QMAKE_EXECUTABLE AND | ||
@@ -1135,12 +1135,12 @@ if (QT_QMAKE_EXECUTABLE AND | ||
@@ -1136,12 +1136,12 @@ if (QT_QMAKE_EXECUTABLE AND | ||
_find_qt4_program(QT_MOC_EXECUTABLE Qt4::moc moc-qt4 moc4 moc) | ||
_find_qt4_program(QT_UIC_EXECUTABLE Qt4::uic uic-qt4 uic4 uic) | ||
_find_qt4_program(QT_UIC3_EXECUTABLE Qt4::uic3 uic3) | ||
|
@@ -54,6 +54,3 @@ index 847a798af..7ad981879 100644 | |
_find_qt4_program(QT_DESIGNER_EXECUTABLE Qt4::designer designer-qt4 designer4 designer) | ||
_find_qt4_program(QT_LINGUIST_EXECUTABLE Qt4::linguist linguist-qt4 linguist4 linguist) | ||
|
||
-- | ||
2.18.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
From 9516fc4260f701c6d9db0c341bb36480362e1747 Mon Sep 17 00:00:00 2001 | ||
From 60864efbe52cc12018efaafbc4e4c3c8b4af2b65 Mon Sep 17 00:00:00 2001 | ||
From: Otavio Salvador <[email protected]> | ||
Date: Thu, 5 Jul 2018 10:26:48 -0300 | ||
Subject: [PATCH 4/5] Fail silently if system Qt installation is broken | ||
Organization: O.S. Systems Software LTDA. | ||
Subject: [PATCH] Fail silently if system Qt installation is broken | ||
|
||
Fixes a regression in behaviour from 2.8.10 to 2.8.11 resulting in the | ||
following error if the system Qt installation is broken: | ||
|
@@ -23,15 +22,16 @@ within the if(QT_QTCORE_FOUND) statement. | |
|
||
Signed-off-by: Moritz Blume <[email protected]> | ||
Signed-off-by: Otavio Salvador <[email protected]> | ||
|
||
--- | ||
Modules/FindQt4.cmake | 39 ++++++++++++++++++++------------------- | ||
1 file changed, 20 insertions(+), 19 deletions(-) | ||
|
||
diff --git a/Modules/FindQt4.cmake b/Modules/FindQt4.cmake | ||
index 7ad981879..8b6f43cda 100644 | ||
index b2a8585..77c89aa 100644 | ||
--- a/Modules/FindQt4.cmake | ||
+++ b/Modules/FindQt4.cmake | ||
@@ -987,25 +987,26 @@ if (QT_QMAKE_EXECUTABLE AND | ||
@@ -988,25 +988,26 @@ if (QT_QMAKE_EXECUTABLE AND | ||
endif() | ||
endmacro() | ||
|
||
|
@@ -77,6 +77,3 @@ index 7ad981879..8b6f43cda 100644 | |
|
||
foreach(QT_MODULE ${QT_MODULES}) | ||
_QT4_ADJUST_LIB_VARS(${QT_MODULE}) | ||
-- | ||
2.18.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,8 @@ | ||
From 0df8d46d14c371f21c327966a553c4c187a8acfe Mon Sep 17 00:00:00 2001 | ||
From fd9a04c1434e12f21c043385e306e0b52d38d749 Mon Sep 17 00:00:00 2001 | ||
From: Otavio Salvador <[email protected]> | ||
Date: Thu, 5 Jul 2018 10:28:04 -0300 | ||
Subject: [PATCH 5/5] Disable use of ext2fs/ext2_fs.h by cmake's internal | ||
Subject: [PATCH] Disable use of ext2fs/ext2_fs.h by cmake's internal | ||
|
||
libarchive copy | ||
Organization: O.S. Systems Software LTDA. | ||
|
||
|
@@ -12,15 +13,16 @@ Upstream-Status: Inappropriate [config] | |
|
||
Signed-off-by: Paul Eggleton <[email protected]> | ||
Signed-off-by: Otavio Salvador <[email protected]> | ||
|
||
--- | ||
Utilities/cmlibarchive/CMakeLists.txt | 8 ++------ | ||
1 file changed, 2 insertions(+), 6 deletions(-) | ||
|
||
diff --git a/Utilities/cmlibarchive/CMakeLists.txt b/Utilities/cmlibarchive/CMakeLists.txt | ||
index 206f3c6a5..642fb0dd9 100644 | ||
index bfcaf30..2960683 100644 | ||
--- a/Utilities/cmlibarchive/CMakeLists.txt | ||
+++ b/Utilities/cmlibarchive/CMakeLists.txt | ||
@@ -430,12 +430,8 @@ LA_CHECK_INCLUDE_FILE("copyfile.h" HAVE_COPYFILE_H) | ||
@@ -682,12 +682,8 @@ LA_CHECK_INCLUDE_FILE("copyfile.h" HAVE_COPYFILE_H) | ||
LA_CHECK_INCLUDE_FILE("direct.h" HAVE_DIRECT_H) | ||
LA_CHECK_INCLUDE_FILE("dlfcn.h" HAVE_DLFCN_H) | ||
LA_CHECK_INCLUDE_FILE("errno.h" HAVE_ERRNO_H) | ||
|
@@ -34,7 +36,4 @@ index 206f3c6a5..642fb0dd9 100644 | |
+SET(HAVE_WORKING_EXT2_IOC_GETFLAGS 0) | ||
LA_CHECK_INCLUDE_FILE("fcntl.h" HAVE_FCNTL_H) | ||
LA_CHECK_INCLUDE_FILE("grp.h" HAVE_GRP_H) | ||
LA_CHECK_INCLUDE_FILE("inttypes.h" HAVE_INTTYPES_H) | ||
-- | ||
2.18.0 | ||
|
||
LA_CHECK_INCLUDE_FILE("io.h" HAVE_IO_H) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters