You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Naming must be right for concepts to be properly conveyed! But naming things is hard! And for the Reactive Contexts Proposal, the choice of conventions for a new approach to reactivity is an especially delicate area; every convention now already means something across the countless different approaches to the subject!
So far, we've made a few iterations...
We had called this the Subscript Functions Proposal, but for many with a React, SolidJS, Vue, (and similar) background, Subscript Functions tended to equate to a useEffect()/createEffect()/watchEffect() callback. But since the whole idea of Subscript Functions is rather about an entire reactive context, a more descriptive name clicked: Reactive Contexts.
Now, we're thinking further...
We currently use the double star function (function** fn() {}) syntax for Subscript Functions, but early feedback had pointed to possible cognitive glitch with Generator Functions (function* fn() {}).
We currently call Subscript's reactivity API .thread(), but it seems we can do better, if we'd just think further 🤨.
reacted with thumbs up emoji reacted with thumbs down emoji reacted with laugh emoji reacted with hooray emoji reacted with confused emoji reacted with heart emoji reacted with rocket emoji reacted with eyes emoji
-
Naming must be right for concepts to be properly conveyed! But naming things is hard! And for the Reactive Contexts Proposal, the choice of conventions for a new approach to reactivity is an especially delicate area; every convention now already means something across the countless different approaches to the subject!
So far, we've made a few iterations...
useEffect()
/createEffect()
/watchEffect()
callback. But since the whole idea of Subscript Functions is rather about an entire reactive context, a more descriptive name clicked: Reactive Contexts.Now, we're thinking further...
function** fn() {}
) syntax for Subscript Functions, but early feedback had pointed to possible cognitive glitch with Generator Functions (function* fn() {}
)..thread()
, but it seems we can do better, if we'd just think further 🤨.Comments are open for thoughtful inputs.
Beta Was this translation helpful? Give feedback.
All reactions